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About YADDStats

YADD is an amazing program for decoding DSC transmissions from coastal

stations and ships. I’ve had a lot of success with it. It is, however, somewhat

limited in terms of record keeping. I wanted something that would both generate

statistics and keep better lists about what I’ve logged. So I wrote YADDStats.

YADDStats is offered free for as-is use under the Apache License. This and other

DX applications that I have written (including all source code) may be found at

the following website. I strongly suggest you only download my applications

from my website as I can't guarantee that the files haven't been tampered with if

you find them at other locations.

http://www.DonMooreDXer.com/dx/apps/

Questions, suggestions, or other comments may be sent to:

DonMooreDXer@Yahoo.com

If you find my applications useful and would like to contribute something,

donations may be sent via PayPal at the above email address. Donations received

will be contributed to www.kiva.org where they will be used to make micro-loans

in Third World countries.

Technical Details

YADDStats is written in C# using Visual Studio 2015. It uses LiteDB, a

light-weight simple no-SQL database system designed for small C# projects.

LiteDB uses a single DLL file and requires no additional installation. LiteDB

stores data in the JSON format in a BSON file (which is JSON data stored in

binary format).  For more information about LiteDB see

https://www.litedb.org/
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Setting Up YADDStats

YADDStats doesn’t need to be installed. Just unzip the YADDStats folder and

place it somewhere on your system. That somewhere should be a place where

Windows won’t complain when new files and folders are created. I keep

YADDStats in my Documents folder but it can be anywhere, even on an external

USB thumb drive.

Windows Security

I write applications primarily for my own purposes and share them with other

DXers. I have not paid the several hundred dollars for licenses which would

allow me to create Windows certified install files. That means when you run

YADDStats for the first time you may get some warnings from your virus

program. You will need to tell your virus program that YADDStats is safe. Or else

don’t use YADDStats. It is possible that some virus programs won’t allow you to

run YADDStats at all. If you are a programmer you could also download the

source code and compile YADDStats yourself.

The Components

Initially the YADDStats folder contains the following files and subfolders:

Main Folder

YADDStats.exe - executable file

LiteDB.dll - database interface

FilesToLoad Folder

SampleFileOne.txt and SampleFileTwo.txt: Small files from my own YADD logs

for testing. I recommend that you store copies of all your raw YADD logs here.

UserData Folder

This contains empty subfolders named Backups, Databases, MMSI, and UNID.

Their use will be explained in the instructions.

Reports Folder

An empty folder used for user-generated reports.
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References Folder

This folder contains several important files.

Frequency List.txt: In the Reports tab, several drop-down boxes allow the user

to specify a frequency. These are loaded from the FrequencyList.txt file in the

References folder. The frequencies can be reordered and additional ones may be

added. The selection boxes in YADDStats will always default to the second

frequency in the list.

CountryList.txt: YADD identifies countries using a mix of one-letter and

three-letter abbreviations and ITU codes. YADDStats replaces the abbreviations

with the country name and adds the continent name using this file. The

abbreviations in YADD vary depending on the version of the station list being

used. For this reason, some countries are listed multiple times in the country list

(e.g. France under ‘F’ and ‘FRA’). Also, some ‘radio countries’ have been added

to later versions of the YADD station list. For example, Las Palmas Radio was

once listed in ‘E’ (Spain) but is now listed in ‘CNR’ (Canary Islands).

As a user you may want to add additional ‘radio countries’ to the list. For

example, I think that if Corsica and Sicily are counted as separate radio

countries, then Sardinia should be, too. So I added ‘Europe,SAR,Sardinia’ to the

country list. The abbreviation is my own and isn’t found in YADD, so it won’t

show up in the YADD logs. But in YADDStats I can change Porto Torres Radio to

Sardinia instead of Italy and have it counted as a different radio country. (See

the Changes and Updates Tab for how to change logged countries.)

MMSI_Ship_List.txt and CoastalStationLocations.txt: See explanation under

Loading Records.

CoastalStationExceptions.txt: See the section on the Changes and Updates Tab.

YADDStats_Instructions.pdf: A copy of these instructions.
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Data Structure in YADDStats

In the Start tab in YADDStats there is a

box for selecting and creating databases.

The boxes will be empty the first time the

program is used. You can have as many

different databases as you want. I currently

have three - one for logs in central

Pennsylvania, one for logs from a

DXpedition to Newfoundland, and one

with all of my DSC logs. If I later DX from

a different location I’ll add those logs to

the DSC_All_Locations database and also

create a new one for that location. Another

option might be to maintain a different

database for each calendar year. Or you

can just have a single database for tracking

everything.

Each database contains three collections (the no-SQL equivalent of tables).

These are named CoastalStations (for coastal stations logged), Ships (for ships

logged), and CoastalStationsCalled (for tracking which coastal stations ships

have called).

Coastal Station records contain the MMSI number, station name, country,

continent, the number of times this station has been logged, and a collection of

frequency information for the station. For every frequency the station has been

monitored on, the records contain the frequency, the total number of times that

frequency has been logged, and the first date/time and most recent date/time

the station has been logged.

Ship records are formatted similarly except that they include the ship name and

ship type instead of station name, country, and continent. If the ship has been

logged with a valid position report, then the frequency, date/time, and position

of that report is also saved. A valid position report is one in which both the

degrees of latitude and degrees of longitude are valid values (even if one or both

of the minutes values have invalid ~~ values). All position reports are saved.

Coastal Stations Called records are just like those of coastal stations logged.
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Databases are stored in the

UserData\Databases folder

in the main YADDStats folder.

Backups are stored in the

\UserData\Backups folder.

Existing backups for the

selected database will appear

in the backup list. Backups

are automatically created

whenever new records are

added to the database. The backup name includes the date and time the backup

was made. Backups can also be created on demand at any time but generally

there should be no need for that.  You may want to occasionally delete the oldest

ones if you have a lot.  To replace a database with a backup just remove the

date/time from the filename and copy it to the Databases folder.

Make JSON Files writes all the collections out in their raw JSON format to the

Backups folder. These files are of no use to YADDStats. But if you want to see

what the actual YADDStats data looks like, load these files into an online JSON

viewer or a text editor using a JSON format plugin (such as NotePad++).
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Preparing the YADD Records

YADD stores logs in an Absolute Database file named DSCLOGS.ABS.  Absolute

Database is a format designed for use with applications written in the Delphi

programming language. Unfortunately, there is no easy way for a C# program to

directly connect to this type of database. So to use YADDStats those records first

need to be saved as a tabbed text file.

There are two ways of doing this. But first you need to find your DSCLOGS.ABS

database.

If you’ve installed YADD in the Program Files folder of Windows, then the

database will be located under AppData at the following location.

C:\Users\YOUR_USER_NAME\AppData\Local\VirtualStore\Program

Files (x86)\YaDD

If you have more than one copy of YADD (e.g. YADD_01, YADD_02) there will

be a folder for each instance.  If you have YADD installed somewhere other than

Program Files, such as in your Documents folder as I do, then the database will

be inside the YADD folder. Regardless of where DSCLOGS.ABS is, I recommend

making a backup copy and working with that.

The first way to create the tabbed file is to use the DBManager.exe application

which is found in the YADD folder.

●Open DBManager.exe

● The manager may open the DSCLOGS.ABS file automatically. If not, from the

menu select File > Open Database and then find and select DSCLOGS.ABS

● Select the Data tab if it hasn’t already been selected.

● From the menu select Table > Export to Excel

●Un-check the ‘RAW’ column

● Click OK

●Now open the just-created file in Excel. Select the File menu, select Save As,

and choose the option for Text (tab delimited) (*. txt).

● If you don’t have Excel but have a Google account, upload the file to your

Google Drive folder, convert it to a Google Sheets file, then from the menu

select File > Download > Tab-Separated Values
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Or … If DBManager.exe doesn’t work (it doesn’t for me), then you will need to

download a program called AbsoluteSQL.

●Go to the webpage http://nknabe.dk/database/absolute/index.htm .

Download AbsoluteSQL.zip from the link towards the bottom of the page.

●AbsoluteSQL doesn’t require installation. Just unzip the folder in a convenient

location.

●Run the AbsoluteSQL.exe application.

● If you get an error message about the Borland engine, ignore it and click OK.

● From the menu select Database > Open Database

● Browse to wherever your DSCLOG.ABS file is and select it.

● This should open with a window that includes the phrase ‘SELECT * FROM

LOG’.

● Towards the right side of the central bar there is a ‘RUN SQL’ button. Click

that to load the records.

● From the menu select Export > Grid Contents to CSV or Tabbed Text File

● Select the ‘Tabulator’ option and click OK.

●Name the file and save it to a convenient location.

If you run multiple copies of YADD each one will have its own database. You will

need to create tabbed-text files from each one.
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Loading Records to YADDStats

This will explain step-by-step how to load files to

YADDStats using the included sample files. Start

YADDStats.  Type TestFile101 in the New DB

text box and click Create New Database.

YADDStats will automatically switch to the Load

Records tab.

Click the Browse for File button, open the

FilesToLoad folder and select

SampleFileOne.txt. (Or you paste the full path

into the text box.) Now click the Load Logged

Stations and Ships button. YADDStats will begin

loading the records and report the progress in

one thousand line increments in the Process box.

When finished YADDStats will

switch to the New Stations tab and

display charts of new stations

logged and new frequencies logged

for already-logged stations.

Everything is new since we are

creating a new database. Clicking

on the Export buttons at the top

will save the information to a CSV

file in the Reports folder. This can

be loaded into a spreadsheet

program and formatted for submitting logs to DX lists and publications. In the

unlikely event that a log contains a country abbreviation that is not found in the

YADDStats country table that will be listed in the Unknown Countries box.

(These should be investigated and added to the country list file.)

Click on the New Ships tab to see the same information for ships logged.

Switch back to the Load Records tab. Now select and load SampleFileTwo.txt

from the FilesToLoadfolder. Only stations and ships not logged in the previous

file are listed in the New Stations and New Ships tabs.
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Unidentified and Identified

YADDStats discards records where the sender’s MMSI number is not fully

decoded. But sometimes YADD fully decodes a nine digit MMSI but is unable to

identify it using the lists in YADD. YADDStats tries to identify those.

Switch back to the Load Records tab. The Process list shows that when the first

file was loaded 137 unknown ship logs were identified and that 209 were

identified in the second file. When loading new records, YADDStats tries to

identify unknown MMSI numbers using files named MMS_Ship_List.txt and

CoastalStationLocations.txt in the References folder. The ship list file was

downloaded from the YADDNet website while the coastal stations file is just

taken copied from a recent version of YADD. These files can be updated at any

time. And if the files in YADD and YADDStats are the same then there would

never be any extra identified ships or stations.

Logs with valid MMSI numbers that YADDStats can’t identify are stored in the

DatabaseName_ShipsUNID.txt and DatabaseName_CoastlUNID.txt files in

the UserData\UNID folder. If later the files in the references folder are updated

the UNID files can be checked against the new records by processes in the

Changes and Updates tab. You can also manually search for the unknown MMSI

numbers online, add the information to the appropriate reference file, and then

run the check.

More Stuff on the Load Records Tab

More Processes: Off to the right are two more processes that can be run. Load

Called Coastal Stations creates a table listing coastal stations called by ships

logged (but not by other coastal stations). Of course these stations haven’t been

logged, but it is interesting to see who ships think they can contact.

The Make and Update MMSI Lists button creates folders named

DatabaseName_MMSICoastal and DatabaseName_MMSIShips inside the

UserData/MMSI folder. Then it makes individual CSV files for each MMSI

number listing all the logs for that station or ship. Running this for all your ship

logs will create a lot of files, but it can be useful if you want to track a particular

vessel.
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More Stuff on the Start Tab

Changes in Raw Tabbed Files: This box has two ways to adjust the tabbed files

created from DSCLOGS.ABS. YADD records are very large because they contain

the information displayed in the YADD datagrid plus the raw FEC code and

formatting data. Selecting a file and clicking on Strip Raw Data From File will

remove the extra data and create a new file named FileName_Trimmed.txt in

the same folder as the original file, which is not changed in any way. YADDStats

works with either file, so the only reason to do this is to save on file size.

Adjust Time in Logs From SDR Recordings: Decoding DSC signals from SDR

spectrum recording files presents a problem in that the date/time displayed in

YADD will not be when the log was actually made in the recording. This feature

corrects that in the tabbed-text files. I

recommend starting out with an empty

DSCLOGS.ABS database in YADD to do

this. Start YADD and then start the

playback of the spectrum recordings in

your SDR program. Note the exact time

the playback started and the exact real

time that the spectrum recording starts,

preferably to the nearest second.

When the playback is finished, save the YADD decode records into their own

tabbed-text file and then select that file in the Changes in Raw Tabbed Files box.

Now put the two date/time values into their respective boxes in the Adjust Times

box. Both values must be entered in YADD format,  e.g. “2021-02-10 03:09:39”

(without the quotation marks). It doesn’t matter how far apart the two values

are. Click the Get Time Difference button and the program will compute the

exact time difference between the two.

If everything looks good, now click the Adjust Time in Selected File button. The

program will load each row in the file, update the date and time, and then save

the row to a new file named OriginalFileName_TimeShifted.txt in the same

directory. The final raw data field will also be removed if that is still in the file,

making the new file significantly smaller than the original. The new file can now

be processed in YADDStats.
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Reports Tab

The real reason for YADDStats - lists and statistics of what has been logged.

Make Coastal Station Lists

This is used to query the records of coastal stations logged according to various

parameters. (The Coastal Stations Called option can be checked to run the same

queries on those.) The results are displayed on the View Station Lists tab.

Whatever is displayed there can be saved to a CSV file in the Reports folder by

returning to this page and clicking on the appropriate button.

A ‘Full List’ query creates a row for every station name plus frequency

combination. For example, if you have logged Cape Town Radio on 6312, 8414.5,

and 12577.0 there will be three rows for that station.  The next three options run

‘full’ queries restricted by frequency, continent, or both. The ‘Simple Station’

queries are used to get lists of stations without any frequency information.

DSC Statistics

This creates statistical data for coastal stations and ships logged or else for

coastal stations called. The results are shown on the View Stats page. The list of

countries logged can be saved to a CSV file in the Reports folder.

Make Ship Lists

Get Ship Lists is used to create lists of ships logged either listing all frequencies

or on a specific frequency. The Position Report query brings back all ship

records with a position report. Clicking on the Save Selected Station List to CSV

File (in the coastal stations box) will also save these lists to the Reports folder.

Create DXMapMaker Lists

See the separate section on this using this.
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View Station Lists Tab

This tab displays lists of coastal stations and ships created in the Reports tab.

Columns may be resized. Click on column headers and drag to reorder the

columns. (These changed settings are not saved.) Clicking in the empty square at

the top-left and then doing Ctrl+C will copy the selected table to a tabbed text in

the Windows clipboard. Or go back to the Reports tab and save the list to a CSV

file. If logged coastal stations are being displayed, then clicking on any row will

open that item in the Make Changes tab.

Here is a partial view of a Full List query of coastal stations logged.

A Simple Station List query

brings back a station list

without the frequency

information.
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Results from a query of position reports.

View Statistics Tab

Various statistics generated from the Reports tab. The list of countries logged

may be saved to a CSV file in the Reports folder. Below are my statistics for

YADD logs in Central Pennsylvania.
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Changes and Updates Tab

YADD uses coastal station information from a file named

YADD_MMSI_COAST.TXT in the YADD folder. There are different versions of

that depending on when YADD was initially installed. In some cases I like using

different station names or country locations. For example, I want to list Porto

Torres Radio and Cagliari Radio as being in the radio-country of Sardinia, not

Italy.

Inside the References folder there is a file named CoastalStationExceptions.txt.

When a coastal station is loaded into YADDStats, the program compares the

MMSI with the MMSI numbers from this file. If there is a match, YADDStats

updates the station name, country, and continent to what is in the exceptions

table. If you don’t like something in the file (maybe you want Porto Torres Radio

to be in Italy, not Sardinia) you can delete that row.

Users can also update the station name and location of coastal stations. In either

the New Stations tab or in the View Station Lists tab when listing Coastal

Stations logged, double-click the row containing the station to be changed.

YADDStats will switch to this tab and you will have the option of changing the

station name and selecting a new country from the list. That will also save the

changed item to the exceptions file. Then those values will be used any time that

same station is loaded to any database you might create in YADDStats.

ReCheck Unidentified Ships and Stations

As explained in the section on loading records to YADDStats, logs with valid but

unidentified MMSI numbers are stored in the DatabaseName_ShipsUNID.txt

and DatabaseName_CoastlUNID.txt files in the UserData\UNID folder.

Whenever the MMS_Ship_List.txt or the CoastalStationLocations.txt files in

the References folder are updated a recheck of the UNID files can be run.

Results will be displayed in the New Stations and New Ships tabs.
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Tips For Using YADDStats

Use A Test Database: Saving YADD logs to a tabbed-text file and loading

them into YADDStats is simple. But I recommend trying a test database first.

Back Up Your Tabbed-Text Files: If you have your original tabbed-text files

you can always recreate your YADDStats database.

Multiple Copies of YADD Are OK: If you run YADD on different computers

or multiple copies on the same computer then all those logs can be loaded into

the same YADDStats database for a set of combined records. You just need to

generate tabbed-text files for each one.

Separate Records Are Good: Another strength of YADDStats is that you can

keep multiple databases. Maybe have a separate database for each year and

another one for all-time logs. Or if you DX from different locations have

databases for each location and a combined one for all locations.

Keep the Counts Accurate - If You Want: Here’s a scenario. You run YADD

for the month of March and then make a tabbed-text file and load those into

YADDStats. A month later you want to bring YADDStats up-to-date so you

repeat the process. But DSCLOGS.ABS still contains the March logs. This

impacts the YADDStats records in two ways.

First, the counts fields - how many times you’ve logged the station on each

frequency and how many total logs - will be inflated because March will be

counted twice. And as you continue each month the problem will be

compounded. If all you want is a searchable list of what you’ve logged and you

don’t care about having accurate counts then this isn’t a problem. Second,

because YADDStat saves all ship position reports, any position reports will be

saved multiple times. There is no effect on this other than making the database a

little larger.

There are two ways this situation can be avoided.

First, the method I use and recommend. Whenever I save YADD logs to a

tabbed-text file I save a backup copy of the database (named to indicate what it

contains) and then delete all records from the DSCLOGS.ABS database in YADD.

Of course I also keep a copy of the tabbed text file and archive both the database

and the text file.  By always starting with an empty DSCLOGS.ABS I never load
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duplicate records. Another benefit is that it keeps DSCLOGS.ABS from growing

too large, which makes it harder to browse through in YADD.

Second, you could make a note of the time of the last log in the March

tabbed-test file. Then when you create the April file find that line and delete

everything from there up. But that can be tedious when working with really large

files.

Problems?

Every effort has been made to assure that YADDStats works perfectly. If

something bad or unexpected happens, YADDStats may produce a file named

Error_Log.txt in the main directory. If you send me that file plus the tabbed text

file you were loading I will investigate the issue.

Potential Updates

If you have any ideas of other things I could add to YADDStats let me know. If

the idea is not too time-consuming I’ll probably do it.

Create DXMapMaker Lists

This is used to create files to generate maps using my DXMapMaker application.

See that application for more details.

Position Reports for All Ships creates a list using saved position report data,

converting the coordinates to the decimal format used by DXMapMaker.

Sometimes ships transmit numerous position reports over a few minutes or

hours so multiple records for the same ship are only used when at least twelve

hours have elapsed between reports. The files are saved to the Reports folder as

PositionRptsForMaps with a date/time stamp in the file name.

YADDStats can also create files for DXMapMaker listing all coastal stations

logged using coordinate data from the CoastalStationLocations.txt file in the
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References folder. These files will be named MapMakerDSCList followed by a

date/time stamp and be placed in the Reports folder. At the same time

YADDStats will create a file named MapMakerDSCList_NoCoordinates listing

stations where no latitude/longitude was found.

The CoastalStationLocations.txt file is a copy of the YADD_MMSI_COAST.TXT

file in YADD with updates I have made.  Unfortunately the original file is

missing data for many stations and even entirely missing some active stations. If

you have any stations listed in the ‘no coordinates’ file you will have to locate

these yourself, add the coordinates (in decimal format) to the

CoastalStationsLocations.txt file, and then rerun the query. Please send any

coordinates you look up to me and I will update the master file.

As to the stations that do have coordinates, I found several wrong values with

stations in Spain and the United Kingdom, which I corrected. After you have

created the map in DXMapMaker I suggest carefully checking all the displayed

coastal station locations in your map and making corrections as needed. Please

send any discrepancies you find to me so I can update the master list.

Below is a small section of a full world map that shows position reports of ships

logged. When the actual map is loaded in a web browser hovering over the red

dot will pop up a small text block listing the ship nme, MMSI number,

frequency, and date/time.
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